JP Vossen on 11 Jun 2008 00:47:25 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] Printing from Windows to CUPS, output sometimes truncated? [Solved, poorly]

On 2008-05-07 JP Vossen wrote:
> I recently switched from sharing a couple of printers from Samba (what a 
> giant PITA to configure) to CUPS (mostly Just Worked).  Except...
> Sometimes when printing from Windows my output is truncated.  For 
> example, I just printed a test page from my XP work machine and I have 
> the the first 5 lines and part of the 6th, but that's it.  Other times 
> it works fine.
> The print server was Gutsy until the weekend but is now running Hardy, 
> which doesn't seem to make a difference.  And it only seems to happen on 
> the inkjet, not the LaserJet 4.
> Windows client-side it's configured as an "Internet printer" at 
> http://hostname:631/printers/OfficeJetK60.  I was amazed at how much 
> easier that was to set up than the old Samba way I was doing it.
> HP OJ K-60 using Common UNIX Printing System 1.3.7:
>     Printer Driver: HP OfficeJet K60 Foomatic/hpijs (recommended)
>     Printer State: processing, accepting jobs, published.
>     Device URI: hp:/par/OfficeJet_K60?device=/dev/parport0

Bottom line up front:
1) I think the real problem is/was that a bunch of things that hpijs 
required were missing.  I'm not sure how that would happen, though.  If 
I'd discovered the hpijs 'hp-check' tool sooner, I might have saved 
myself some work and found a better solution.

2) But since I didn't find that, I switched from hpijs to hpoj and that 
worked (I suspect because hpoj has lots fewer dependencies).  hpoj is 
sub-optimal, in that it doesn't have nearly the tools that hpijs has 
(NOW you tell me), but for now it works...


I was using:
	hpijs - HP Linux Printing and Imaging - gs IJS driver (hpijs)

but switching to this:
	hpoj - HP OfficeJet Linux driver (hpoj)

*seems* to have fixed it, thus far anyway.  Since the Ubuntu Hardy host 
machine rebooted during a power failure anyway, I took the opportunity to:

* fully update it
* sudo aptitude install hpoj
* run 'sudo /etc/init.d/hpoj setup' which found the printer right off
* Delete the old printer and attach to the new one in System,Admin,Printing
* Go point the 2 Windows at the "new" printer and delete the old one
* Test a document that had previous totally failed to print right from 
both Ubuntu and W2K.  It worked flawlessly from both this time.

Note the changes :
	Printer Driver: HP OfficeJet K60 Foomatic/hpijs (recommended)
	Device URI: hp:/par/OfficeJet_K60?device=/dev/parport0
	Printer Driver: HP OfficeJet K60 Foomatic/hpijs, hpijs 2.8.2
	Device URI: ptal:/mlc:par:OfficeJet_K60

I also installed this just for kicks:
	hpoj-xojpanel - HP OfficeJet Linux QT-based LCD panel display

Now then, that seems to have "fixed" it, but in goofing around I found 
out a bunch more stuff.  I suspect I could have really fixed the other 
"hp:" driver if I'd thought to do something like this:
	apt-cache show hpijs hplip hpoj | less
	dpkg -L hplip | less

Because that would have brought me to 'hp-check', which complains about 
a bunch of missing things [1](why they aren't dependencies in the .deb 
is an open question).  Other interesting things include hp-timedate (I 
was wondering about that), hp-setup (which (re-)installed the "old" 
printer driver that's (still) broken), and the very cool hp-toolbox.

Note, running *both* hpijs and hpoj won't work as they step all over 
each other.

Thanks for the previous help and I hope this is useful for someone else,
[1] Missing stuff:
JP Vossen, CISSP            |:::======|        jp{at}jpsdomain{dot}org
My Account, My Opinions     |=========|
"Microsoft Tax" = the additional hardware & yearly fees for the add-on
software required to protect Windows from its own poorly designed and
implemented self, while the overhead incidentally flattens Moore's Law.
Philadelphia Linux Users Group         --
Announcements -
General Discussion  --