jazzman on 8 Jul 2008 19:15:43 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] USB Hub Blocks Web Cam

I ran into this issue before as well. I found, after some digging, that 
there is some known issue in V4L where a camera like a quickcam (may be 
quickcam specific... not sure) must be the ONLY device on a root hub or 
else you'll actually get a kernel fault (at least that's what I found and 
verified it was not just me... google was my friend).

USB Hubs count as another device on the root hub, so remove that. Try just 
the camera and nothing else and I bet it works.


 On Mon, 7 Jul 2008, Casey Bralla wrote:

> Here's a weird one I don't understand.  Maybe somebody can help me understand 
> what is going on.
> I've been goofing around with a Logitech QuckCam I got a while ago "free" from 
> comcast.   It's well supported by Linux, although anything but great image 
> quality.
> Anyway,the darn thing wouldn't work and I finally figured out that it was 
> because it was being hooked up through a USB hub.   If I plugged it directly 
> into my computer, it worked fine (well, as good as it ever would).  If I 
> plugged it into a hub, it would not produce an image.   
> lsusb sees it through the hub, but I couldn't get xawtv to pull an image from 
> it.
> I duplicated the problem with another hub, and got the same result.  One of 
> the hubs was powered, one was static.
> Can anybody explain this?  I'd like to use it through a hub (much cleaner 
> wiring), but I don't even know what type of hub (if any) I should buy to make 
> it work.
> Any comments, prognostications, disertations, or suggestions would be very 
> much appreciated.

Philadelphia Linux Users Group         --        http://www.phillylinux.org
Announcements - http://lists.phillylinux.org/mailman/listinfo/plug-announce
General Discussion  --   http://lists.phillylinux.org/mailman/listinfo/plug