Casey Bralla on 27 Jul 2008 09:20:24 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] reinstalling grub

Art, the steps you have taken all seem reasonable to me.   I've included my 
thoughts below

On Sunday 27 July 2008 9:09:54 am Art Alexion wrote:
> I have been frustrated in my efforts to revive my Kubuntu Hardy system. 
> While I am hoping that grub is the sole issue, there is an unlikely
> possibility that there is a problem with the primary SATA hard drive.  The
> drive (sda) has three partitions: sda1=/boot, sda2=/, and sda5=swap.  sda1
> & 2 are ext3, sda1 being primary and sda2, LVM.

You could very well have a problem with your drive.  If you can mount them, 
then this tends to indicate otherwise, but I'd back up any data just to be 

> I tried restoring grub by booting a feisty or gutsy alternate install disk,
> using the restore boot and executing 'grub-install /dev/sda1'.  It would
> find /boot and then hang.  Eventually I found a pseudo-gui ncurses "install
> grub feature that seemed to work, but when I tried booting, it got stuck
> repeating "Loading stage 2".

I always got confused by the automated install and preferred to use the manual 

> Thinking this may be related to trying to use an older version than
> currently installed on the hard drive I burnt hardy regular and alternate
> install disks.  The alternate install seemed to freeze on 'grub-install
> /dev/sda1', and the gui-like command wanted to partition the drive first.
> The 'ls /dev/sda<tab> showed the partitions, and the partitioner saw them
> as well.  The lvm '/' partition showed up twice, as sda2 and
> as /dev/mapper/chubby/root.
> Booting from the regular live install gave me access to the full array of
> command line to run grub-install, but from konsole, the command failed,
> with the error that it couldn't fine /boot.  Konqueror's media:/ kio saw
> the boot partition and mounted it, showing all the files that I expected
> there.  It did not show the kvm '/' partition.

Not finding the "/" partition sounds ominous.   That may support the "bad 
disk" hypothesis..

> I gound a web page that suggested running
> # grub
> > root (hd0,0)
> > setup (hd0)
> grub found hd0 with the <tab>, but couldn't find boot.  I went through and
> tried all of the hd's incase sda was't hd0 (there is also an hda on the
> system) with the same result.

This is the manual install method.   I've only had it fail when I've put in 
the wrong device numbers or gotten the syntax wrong.  Could you post the 
errors it shows when it fails?

> Yep, I don't have a recent backup of /home and didn't save it in a separate
> partition, so I don't want to repartition and blast everything.
> Please give me your thoughts on the following points:
> * Is there something I am missing in the above steps?

No.  I think you've explored the possibilities properly.   However, you've 
worked very hard on multiple avenues, so it is possible that you've gotten 
yourself frazzled and are missing something that is "obvious".   You may want 
to put it away for a few hours and look at it freshly later.

> * Does the lvm have something to do with my problem?

Hmmmm.    I've never used LVM, so can't be sure, but it can only add to the 

> * I'd like to try backing up the "/" partition and reinstalling the system,
> but wonder about the easiest way to do this as the live CD doesn't see it.
> * Would knoppix do any of this better? I don't have a copy at home.
> * any other suggestions?

If the disk is OK, Knoppix will find the partition.   To do an emergency 
backup, I like to boot to a live CD, then sftp the files to another computer.

> I'll appreciate any help anyone can offer.

Can you install the disk in another computer and see if it can find the root 

Good luck!


Casey Bralla
Chief Nerd in Residence
The NerdWorld Organisation
Philadelphia Linux Users Group         --
Announcements -
General Discussion  --