JP Vossen on 9 Dec 2008 21:06:03 -0800

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[PLUG] Brother MFC-9840CDW & Linux

I thought I'd follow-up and let everyone know how my recent printer 
question worked out.  I got the Brother MFC-9840CDW on sale at Newegg 
for $530, and got it in 2 days, which was a surprise since it's huge and 
weighs 85 pounds.  (Actually, I got 2, and shipping was only about $60. 
  I'm very pleased.  The other printer is for someone else.)

Thus far, it works great!  The bad news is that Linux is still a second 
class citizen.  The good news is that it's an official citizen at all.

The Gritty details
The "main" web site and all promo materials list only Windows and Mac, 
but Linux support is official and maintained.  Oh yeah, except firmware 
upgrades via Windows or Mac only, as far as I saw. :-/

The Linux drivers were trivial to install and with one exception Just 
Worked.  They are available in deb or rpm, but curiously not tgz; they 
recommend using alien to extract the tgz.  And that's typical of 
Brother's "separate-and-not-quit-equal, not quite as slick as Win/Mac" 
Linux approach.  The Linux material is well done but requires a mixed 
skill level.  Most is very easy step-by-step, but then there's the 
occasional oops like this "use alien for tgz" thing, when it would be 
far easier for them to just post the darn tgz with the deb and rpm.  So 
we're talking 'dpkg -i' and not 'make && make install' but we're not up 
to the point-n-click auto-run fancy GUI stuff.  (Some may argue that's a 
good thing, but Ubuntu is proving that slick has a place. :)

The part that didn't Just Work is that they seem to put CUPS stuff in a 
place that Ubuntu's App Armor config doesn't like, so you have to put 
that into "aa-complain" mode for cupsd (see the FAQ below).

The Windows printer drivers were fine.  The CD runs a Flash app (but 
only on Windows, so--why now?) with a bunch of choices.  I only 
installed the over-the-wire printer driver, I don't care about scanning, 
administering, monitoring, or anything else on Windows.  The tools look 
slick and complete, from what I saw of them.  Just for the heck of it I 
installed that Mac tools on my old PPC Mac Mini.  It *forced* me to 
reboot, which not even Windows did!  Though to be fair it installed all 
of the tools (since it never gave me a choice).  I can't find the 
duplexer. though since I was only test printing one page maybe, 
Mac-like, it didn't give me the option.

I am only using the Ethernet interface, but it has USB and wireless too. 
  The Linux CUPS printer drivers expose all the bells and whistles I'm 
interesting in, especially including the duplexer!  **Scanning using 
Xsane worked out-of-the-box over the wire!**  (Well, after I trivially 
installed the drivers.)  The unit has scan to email, ftp server and 
other settings as well.  I've also set it to email me a weekly report on 
itself.  Of course it has a built-in web server, which is a lot easier 
to use than the front keypad for config options.  The keypad isn't bad, 
it's just--a keypad.

One minor web interface grip is that if you goof up a setting, like by 
putting dashes in the fax station ID, the web server won't give you an 
error, it will just totally ignore that setting, which is annoying. 
There's no built-in NTP server that I see either, so you have to 
manually set the clock.  Hell, I could automate that even on my ancient 
HP OJ K-60!  Though now that I think about it, I could probably script 
an HTTP-POST to set the time. :-)

One other minor gripe is that my old HP OJ K-60 had an auto-answer 
button for the fax part.  This printer has a gazillion cool fax options, 
but they are menu-driven.  To switch between my 99.9% manual to my 0.01% 
waiting-for-a-fax modes will be harder than hitting 1 button on or off. 
  Or I can stand there and hit a button when the fax comes in.  Oh well.

What printing and scanning I've done so far is crisp and clear; it just 
looks great.  A full page color photograph printed in seconds, even from 
sleep mode.  I scanned something at 1200DPI and it took quite a while, 
but it worked, right into Xsane on Ubuntu 8.04.  Regular scanning at 
200-400DPI was about as fast as I expected.

The printer is large and heavy, dead quiet while sleeping and reasonably 
quiet when printing even while duplexing.  Quiet is important because it 
sits right next to me.  It's drawing 18 watts while sleeping but hit 
1000 several times and 1200 watts once during power-up, according to my 

Useful links:
App-Armor issue:

Thanks for the help,
PS--In case anyone cares, here's the unit's HTTPd info.  Sort of:
	$ lwp-request -eUd http://nnn.nnn.nnn.nnn
	User-Agent: lwp-request/2.06

	Content-Type: text/plain
	Client-Date: Sat, 06 Dec 2008 07:30:01 GMT
	Client-Warning: Internal response

And an nmap scan.  Lots of protocols, bad TCP Sequencing, and something 
about the scan made a line of gibberish to be printed on 1 page:

# nmap  -P0 -O -v -sS -sU -sR -p 1- -oN nmap.scan printer

Starting Nmap 4.11 ( ) at 2008-12-06 16:05 EST
Initiating ARP Ping Scan against 192.168.xx.xx [1 port] at 16:05
The ARP Ping Scan took 0.01s to scan 1 total hosts.
DNS resolution of 1 IPs took 0.10s.
Initiating SYN Stealth Scan against 192.168.xx.xx [65535 ports] at 16:05
Discovered open port 23/tcp on 192.168.xx.xx
Discovered open port 21/tcp on 192.168.xx.xx
Discovered open port 80/tcp on 192.168.xx.xx
Discovered open port 25/tcp on 192.168.xx.xx
Discovered open port 54923/tcp on 192.168.xx.xx
Discovered open port 54921/tcp on 192.168.xx.xx
Discovered open port 9100/tcp on 192.168.xx.xx
Discovered open port 54922/tcp on 192.168.xx.xx
Discovered open port 515/tcp on 192.168.xx.xx
Discovered open port 631/tcp on 192.168.xx.xx
The SYN Stealth Scan took 7.54s to scan 65535 total ports.
Initiating UDP Scan against 192.168.xx.xx [65535 ports] at 16:05
The UDP Scan took 9.44s to scan 65535 total ports.
Initiating RPCGrind Scan against 192.168.xx.xx at 16:05
Discovered open port 69/udp on 192.168.xx.xx
The RPCGrind Scan took 4.07s to scan 16 ports on 192.168.xx.xx.
For OSScan assuming port 21 is open, 1 is closed, and neither are firewalled
Host 192.168.xx.xx appears to be up ... good.
Interesting ports on 192.168.xx.xx:
Not shown: 131054 closed ports
21/tcp    open          ftp
23/tcp    open          telnet
25/tcp    open          smtp
80/tcp    open          http
515/tcp   open          printer
631/tcp   open          ipp
9100/tcp  open          jetdirect
54921/tcp open          unknown
54922/tcp open          unknown
54923/tcp open          unknown
69/udp    open          tftp
137/udp   open|filtered netbios-ns
138/udp   open|filtered netbios-dgm
161/udp   open|filtered snmp
3702/udp  open|filtered unknown
5353/udp  open|filtered unknown
MAC Address: 00:80:77:xx:xx:xx (Brother Industries)
Device type: VoIP gateway
Running: AudioCodes embedded
OS details: AudioCodes MP-108 VoIP Gateway FXS
Uptime 0.010 days (since Sat Dec  6 15:50:40 2008)
TCP Sequence Prediction: Class=trivial time dependency
                          Difficulty=1 (Trivial joke)
IPID Sequence Generation: Incremental

Nmap finished: 1 IP address (1 host up) scanned in 25.636 seconds
            Raw packets sent: 131106 (4.720MB) | Rcvd: 131099 (6.687MB)
JP Vossen, CISSP            |:::======|        jp{at}jpsdomain{dot}org
My Account, My Opinions     |=========|
"Microsoft Tax" = the additional hardware & yearly fees for the add-on
software required to protect Windows from its own poorly designed and
implemented self, while the overhead incidentally flattens Moore's Law.
Philadelphia Linux Users Group         --
Announcements -
General Discussion  --