jeff on 27 Dec 2008 14:12:41 -0800

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[PLUG] 8.04 to 8.10 Ubuntu-ings

My Dell E4300 laptop has been running on Xubuntu 8.04 since I got it. 
Was hesitant to try 8.10 because it wasn't proven (back when I started 
testing it on other machines).

One thing that *really* ticked me off was that the touchpad scrolling 
refused to function.  Yes, it's a small thing, but it's important to me. 
  There were a number of similar little things that didn't work, none of 
which spring to mind at the moment.

Something happened.
What, you ask?
That's a very good question.  I remember I was sitting in my Official 
Laptop Chair and getting really agitated because the laptop was refusing 
to do something or other.

Oh yeah, it developed an `interesting' video anomaly: it locked when I 
went to play videos with VLC.  I know VLC as rock solid and cross 
platform.  It certainly did not START this way, it just kinda popped up 
one day.  I never felt brave enough to try fixing it so I left it (ok 
because it was mainly to VPN into work, where I don't need to play videos).

Perhaps it was the 4 day weekend, perhaps I was feeling bored, perhaps 
the lack of anything actively exploding at the moment gave me the 
impetus to have a go at the little bugger (13.3" screen).  It obliged me 
by going totally black every time I tried to play a video, regardless of 
player.  It would just sit there and stare at me.  If I hit ctl-alt-del, 
it would reboot reliably.

Some Googling for video drivers and troubles produced little and the 
idea of upgrading spontaneously occurred to me.  This is how many things 
tend to happen in my life, so I usually go with it.

It took its time but the upgrade went smoothly (except for those DO YOU 
WANT TO REPLACE CONFIG FILE questions - like I remember how I might have 
unconventionally configured something months -or days- ago).

After rebooting, the touchpad's scroll function WORKED!  It was like 
magic.  It's an awful shame I couldn't say the same about the 
networking.  I connect primarily with wireless but there was no apparent 
way to find anything related to networking (in Xubuntu's menus).  I 
managed to find it via CLI, which indicated everything was as it should 
be.  This was rather unfortunate, as I still had no networking.

I remembered one laptop where everything was set correctly but the 
wireless switch, which never worked, had suddenly become functional and 
required toggling.  Off I went, looking for the wireless switch, which, 
as it turned out, was ON.

Remembering my endless Windows training, I rebooted.  And POOF - there 
was wireless, just like it never left.  I can't explain it but I am more 
than happy to just go with the results. [fyi, this is one of those 
Broadcom ndiswrapper from hell deals]

So there's a success story.  It happens so infrequently that sometimes I 
have trouble typing it out.  Perhaps an upgrade will solve some of your 
weird(er) hardware issues.


I have that issue where I'm typing along merrily when all of the sudden, 
the cursor hops up a paragraph or two and starts typing there (with my 
help, of course).  As I understand it, this is due to brushing the 
touchpad while typing, although I suspect it can also be caused by 
LOOKING AT the touchpad or THINKING ABOUT the touchpad while typing. 
The initial solution, something along the lines of Synaptics (not to be 
confused with Ubuntu's Synaptic pkg mgr) failed to provide relief 
because it couldn't be configured. The instructions wanted a line 
inserted into xorg.cfg, which is kinda useless in Ubuntu 8.10 due to the 
Gee Whiz Interrogative Icthyopteryx Va-Va-Va-VOOM-Video subsystem (new 
to this release).

Look up Touchfreeze.  It's cross-platform too.  Seems to be working thus 
far (notice I qualified that thoroughly).


I don't shut my desktops down.  Lately I've been noticing humongous 
amounts of memory being used with almost no apps open.  Even when I 
close all the GUI apps, it still indicates north of 70%.  I initially 
figured it was Firefox leaking memory but I shut it down.  Htop 
indicated it was xorg.

I realize there are a certain amount of resources necessary to put 
things onscreen for a few days/weeks, but there used to be a time when I 
couldn't tell you the last time I rebooted.  Now it looks like a week or 
more.  I thought it might be dual monitor systems but it occurs with 
single monitor systems too.  Is something not releasing RAM or does xorg 
think it will gain greater market share by behaving like Windows?

All of the systems are Xubuntu 8.10 but I remember it happening on 8.04 
too.  And this is supposed to be the `light' desktop... go figure.

... The healthcare crisis will end when Congress has to choose an HMO
* TagZilla 0.066 *
Philadelphia Linux Users Group         --
Announcements -
General Discussion  --