Rob Moore on 5 Mar 2009 08:01:38 -0800

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[PLUG] Trouble with updates

I’ll preface my email by saying that I am new to supporting Linux. A few months ago I (a Windows Server guy) inherited the job of supporting a few Linux servers when our previous Linux guy left the department. Since then I’ve been trying to learn a few things about Linux. One thing I do is the updates on a regular basis, about once a week. Then, a couple of weeks ago, version 5 of Linux came out and the number of updates jumped waaay up. And now my updates don’t work. Every time I try to run kpackage, I get an error about packages with unmet dependencies. For example, I’m looking at one now that says “The following packages have unmet dependencies. Libperl5.8: Depends: perl-base (= 5.8.8-11.1+lenny1) but 5.10.0-19 is to be installed. E: Broken packages” Another one gives an error about clamav-freshclam.
I’m not sure what to do. The former Linux manager said, “Wait a week or two and all that stuff will get fixed.” Well, it’s been a couple of weeks, and things are still broken.
What to do?
I’m using Debian version 4.0.
Rob Moore
Network Manager
American Friends Service Committee
Philadelphia Linux Users Group         --
Announcements -
General Discussion  --