Chad Waters on 5 Mar 2009 08:14:27 -0800

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] Trouble with updates

> Hello—
> I’ll preface my email by saying that I am new to supporting Linux. A few
> months ago I (a Windows Server guy) inherited the job of supporting a few
> Linux servers when our previous Linux guy left the department. Since then
> I’ve been trying to learn a few things about Linux. One thing I do is the
> updates on a regular basis, about once a week. Then, a couple of weeks ago,
> version 5 of Linux came out and the number of updates jumped waaay up. And
> now my updates don’t work. Every time I try to run kpackage, I get an error
> about packages with unmet dependencies. For example, I’m looking at one now
> that says “The following packages have unmet dependencies. Libperl5.8:
> Depends: perl-base (= 5.8.8-11.1+lenny1) but 5.10.0-19 is to be installed.
> E: Broken packages” Another one gives an error about clamav-freshclam.
> I’m not sure what to do. The former Linux manager said, “Wait a week or two
> and all that stuff will get fixed.” Well, it’s been a couple of weeks, and
> things are still broken.
> What to do?
> I’m using Debian version 4.0.

Debian 4.0 "etch" will supported for another year. I'd stick with that
until you do some research. I don't know what this machine is doing. I
wouldn't blindly upgrade it.

Can you post your /etc/apt/sources.list ??

I have a feeling its referencing the rolling "stable" depository,
instead of referencing the 4.0 release "etch". That's a quick fix if
that's the case.

Philadelphia Linux Users Group         --
Announcements -
General Discussion  --