TuskenTower on 8 Apr 2009 09:43:05 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] Non-linux loobpack weirdness, does not responds

On Wed, Apr 8, 2009 at 12:16 PM, Russ Nelson <russ@cloudmade.com> wrote:

On Apr 8, 2009, at 11:58 AM, TuskenTower wrote:

> On a Linux machine, pinging will reach the localhost host
> and respond.  On a Solaris 9 and AIX machine this does not happen.

Yeah, this is as expected.  You can think about it this way: On Linux,
the localhost interface has a netmask of 255.  On BSD / SysV, the
interface has a netmask of  I'm abusing the term
netmask since it's usually applied to routes, not host addresses, but
it's the concept.

It's kinda nice on Linux because you can run multiple local services
on different IP addresses and the same port.  Handy for services like
DNS where the port is not changable but the IP is.

You might (I haven't tried this) be able to configure multiple IP
addresses on your BSD / SysV loopback interface.  Try "ifconfig lo1" and see if it whinges at you.  Or there's usually an
ifconfig syntax for adding an IP address to an Ethernet interface.
See if it works with lo0 as well.

I cribbed the command from somewhere online:
ifconfig lo0:100 plumb up

That worked on Solaris.  Not going to fiddle with the AIX box.


Philadelphia Linux Users Group         --        http://www.phillylinux.org
Announcements - http://lists.phillylinux.org/mailman/listinfo/plug-announce
General Discussion  --   http://lists.phillylinux.org/mailman/listinfo/plug