JP Vossen on 21 Apr 2009 09:46:54 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] More on Mini 9 with Ubuntu & Wireless

> Date: Tue, 21 Apr 2009 06:52:36 -0700 (PDT)
> From: Edmond Rodriguez <>
> I would try turning off the WPA on the router and temporarily making
> it unsecured (if you aren't worried about doing that).   Then try
> connecting to it, and maybe even try the command line iwconfig.
> Could it be the WPA part that is not working?   Or perhaps you
> already did that.

Yup, did that a while ago, though I forgot to mention it.  That works
better.  The old firmware [1] in the Actiontec claimed to support WPA,
but it never actually worked.  It worked OK in the clear or with WEP.

Then I got the newer firmware [2] and WPA started to kinda work.  This
is why I said the problem is probably 50% Actiontec and 50% Broadcom; it
seems like a timing issue.

[1] v4.    (claims WPA, but busted)
[2] v4. (WPA2, works, released Feb 11 2009)

So having said all of that, I'd blame the Actiontec 100%, except I've
also had problems connecting elsewhere, notably at the 2009-04-13 PLUG N
meeting where I was sitting 2 feet from the Brent's demo OpenWRT box.
We didn't try *that* hard, but no one in the room could get my Mini-9 to
connect.  But Lyz's Mini-9 worked fine (with the same card, but stock

I know, that will sound like "bad card" to everyone.  And maybe it is.
But I also may have a self-inflicted foot wound, in that I was messing
around turning off stuff I didn't want, or didn't think I needed.  It's
still not clear, but I had turned the Avahi daemon off (and purged it),
and it seems like that might have been a factor.  With my new Jaunty
install I left that alone.  Also in the mix is that it has both worked
and not worked elsewhere...  And I've fiddled around quite a bit and am
starting to forget when I did what...

> Though perhaps unrelated, I often have to rerun my WPA connection
> (wpa_supplicant) to make it work.  Powering down the router and
> restarting usually solves the problem.  Though if I run Windows,
> I do not need to do that.

Using Ubuntu 8.04, 8.10 or 9.04 with NetworkManager, I have not had to
do that.  If I've dropped NetworkManager has automatically tried to
reconnect, though with the usual timing issues.  And once connected it
has otherwise been stable.

Thanks for thinking about it,
JP Vossen, CISSP            |:::======|
My Account, My Opinions     |=========|
"Microsoft Tax" = the additional hardware & yearly fees for the add-on
software required to protect Windows from its own poorly designed and
implemented self, while the overhead incidentally flattens Moore's Law.
Philadelphia Linux Users Group         --
Announcements -
General Discussion  --