JP Vossen on 28 Oct 2009 13:05:53 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] aptitude/apt-get DB issue (fixed, fyi)

Well, it just happened again.  I've done almost nothing on this machine 
but Thunderbird & Firefox, but I did one last 'aptitude update' then 
'aptitude full-upgrade' before the servers are crushed tomorrow, and I got:
(Reading database ... dpkg: unrecoverable fatal error, aborting:
  failed in buffer_read(fd): files list for package `libprotobuf3': 
Input/output error
E: Sub-process /usr/bin/dpkg returned an error code (2)

The difference this time is that I streamlined the recovery process 

# rm /var/lib/dpkg/info/libprotobuf3.list
# dpkg --no-debsig --no-triggers --force-all -r libprotobuf3
# aptitude install libprotobuf3

Thus far that worked.  I'm really confused as to why only 
/var/lib/dpkg/info/*.list files are getting mangled.  I still suspect 
the ext4 driver isn't ready for prime-time, possibly for SSDs/Atom/LPIA. 
  I can see them wanting to get ext4 out the door before the 10.4 LTS, 
but...  Or maybe there's a bad dpkg/aptitude package.  Sigh.

I think I have an outstanding kernel upgrade to reboot into, so I'll try 
that.  Otherwise, I have not yet checked for Mini9 or SSD firmware 
upgrades; the SSD is third-party and I really hate firmware updates 
anyway.  I'd suspect a bad SSD but it's only those specific .list files 
that I know of, and the whole-disk image recovery worked fine last time.

JP Vossen, CISSP            |:::======|
My Account, My Opinions     |=========|
"Microsoft Tax" = the additional hardware & yearly fees for the add-on
software required to protect Windows from its own poorly designed and
implemented self, while the overhead incidentally flattens Moore's Law.
Philadelphia Linux Users Group         --
Announcements -
General Discussion  --