John Karr on 2 May 2010 20:30:20 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] Problems using multiple Samba servers in a Win2003 AD domain

I had previously working samba configuration which don't work anymore, I
believe that the current version of samba is broken, or at least the ubuntu
packages are. I currently have Linux machines able to mount windows shares,
but windows machines cannot mount windows shares. Since I have a couple of
times gotten to a point where Linux shares were available through net use,
but could not be accessed through the windows gui, I believe that something
microsoft did is responsible. 

I believe that the best Linux/Windows integration is in the commercial
version of SUSE, I haven't tried openSuse recently so I can't tell you if
that is spilling over to the free version. But overall I've drunken the
Ubuntu KoolAid and ditched KDE, so I wouldn't want to be pushed back to an
RPM/KDE distribution. 

-----Original Message-----
[] On Behalf Of Michael Leone
Sent: Sunday, May 02, 2010 5:38 PM
To: Philadelphia Linux User's Group Discussion List
Subject: Re: [PLUG] Problems using multiple Samba servers in a Win2003 AD

I run mount as sudo. ;-) The account listed as the "username" on the
mount is my domain account, which is a Domain Admin. That same account
is used to mount the shares from the Windows machines, and those mount
commands work. Just doesn't work to mount a share from another Samba

I've tried "mount -t smbfs", "mount -t cifs", "smbmount" - nothing
works, to allow me to mount a share from the Samba server. All 3 work,
to let me mount a share from a Windows client.

On 5/2/10, Eric at <> wrote:
> Hash: SHA1
> Mike:
> On 05/02/2010 04:07 PM, Mike Leone wrote:
>> I've been at this for days, and making no headway. It's very
>> discouraging. I have a Win2003 domain, that has the Services for Unix
>> extensions installed. I am trying to have multiple Samba servers as
>> domain members. (in my case, one desktop sharing files, and one laptop,
>> accessing the shares). And at the moment, it doesn't (fully) work.
>> Each Samba server can see shares from the other. Windows clients can see
>> and mount shares from each Samba server. Each Samba server can mount
>> shares from Windows clients on the domain. What they can't do ... is
>> mount shares from each other. I get
>> mount error(13): Permission denied
> Question: do you run this as a user who has permission to run mount?  I
> recall
> that I had to do something to the permissions on /bin/mount to get mine to
> work
> as a user.  That was 5 years ago so my recollection is a bit foggy.
> Hope that helps.
> Eric
> - --
> #  Eric Lucas
> #
> #                "Oh, I have slipped the surly bond of earth
> #                 And danced the skies on laughter-silvered wings...
> #                                        -- John Gillespie Magee Jr
> Version: GnuPG v1.4.9 (GNU/Linux)
> Comment: Using GnuPG with Mozilla -
> iEYEARECAAYFAkvd7csACgkQ2sGpvXQrZ/5NbgCfeXbUt6i+8EAI9QWHfRx7t7Bx
> srMAoINwrrBoK7pguPCSkk6PrtQauOqn
> =0fFN
> Philadelphia Linux Users Group         --
> Announcements -
> General Discussion  --

Sent from my mobile device

Michael J. Leone, <>

PGP Fingerprint: 0AA8 DC47 CB63 AE3F C739 6BF9 9AB4 1EF6 5AA5 BCDF
Photo Gallery: <>
Philadelphia Linux Users Group         --
Announcements -
General Discussion  --

Philadelphia Linux Users Group         --
Announcements -
General Discussion  --