JP Vossen on 1 Jun 2010 11:52:09 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[PLUG] Collegeville, PA FiOS now blocking outgoing port 25

I *think*...  I did not fully test it, but as of last night/early this 
morning, I was unable to connect to my hosted server on port 25.  The 
server was up and fine, sIMAP & SSH worked fine, and port 25 to that 
server worked from elsewhere (Comcast in NJ, among others).

The solution is easy enough, if slightly tedious:

1) On the server, vi /etc/postfix/ and uncomment the 
"submission" line, then restart postfix.
1.1) Make sure 'submission' is defined in /etc/services:
	grep '^submission' /etc/services

2) Change all the client configs to use port 587 in the GUI 
(workstations) or the Nullmailler config (servers), e.g.:
	sudo sh -c "echo ' smtp --port=587' \				  > 
/etc/nullmailer/remotes" && cat /etc/nullmailer/remotes
	vi etc/postfix/  # for internal postfix hub
		relayhost =

I'm not sure messing with /etc/postfix/ is the *best* solution, 
since that will now collide with future package updates.  It wasn't 
obvious how to do that in, and this was quick & dirty & worked. 
  OTOH, that's what this says to do too:

JP Vossen, CISSP            |:::======|
My Account, My Opinions     |=========|
"Microsoft Tax" = the additional hardware & yearly fees for the add-on
software required to protect Windows from its own poorly designed and
implemented self, while the overhead incidentally flattens Moore's Law.
Philadelphia Linux Users Group         --
Announcements -
General Discussion  --