Mike Sheinberg on 3 Jun 2010 07:34:25 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] Clonezilla CentOS LVM boot issues

Errr. As an update, I just picked up the following clue when trying to run more diagnostics from systemrescuecd:

(results of fdisk -l):
root@sysresccd /mnt/backup % fdisk -l

WARNING: The size of this disk is 2.5 TB (2499946741760 bytes).
DOS partition table format can not be used on drives for volumes
larger than (2199023255040 bytes) for 512-byte sectors. Use parted(1) and GUID 
partition table format (GPT).

Disk /dev/sda: 2499.9 GB, 2499946741760 bytes
255 heads, 63 sectors/track, 303934 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x1549f232

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          13      104391   83  Linux
/dev/sda2              14      121601   976655610   8e  Linux LVM

Seems I tried to throw this system on a drive that was too large for the partition table to handle. Hrmmm.. Well if I can't fix it by the end of today I guess I'll let it Clone again over night after I get the RAID down under 2TB.


On Thu, Jun 3, 2010 at 10:21 AM, Mike Sheinberg <m.sheiny@gmail.com> wrote:
Hello open-source friends :)

I'm having some issues booting a cloned CentOS x86 server that I moved from a single drive desktop to a RAID 5 server. It seems that everything got transferred over successfully but when I boot I get the following show-stopping error:

Scanning logical volumes
Reading all physical volumes. This may take a while...
Activating logical volumes
Volume group "VTPsystem" not found
Creating root device. 
Mounting root filesystem.
mount: could not find filesystem '/dev/root'
SEtting up other filesystems.
SEttuping up new root fs
setuproot: moving /dev failed: no such file or directory
no fstab.sys, mounting internal defaults.
setuproot: error mounting /proc : no such file or directory
setuproot: error mounting /sys : no such file or directory
Switching to new root and running init.
unmounting old /dev
unmounting old /prov
unmounting old /sys
switchroot: mount failed: no such file or directory
kernel panic - not syncing: Attempted to kill init!

When I boot to 'systemrescuecd' I'm able to mount and see my LVM file-systems ('VTPsystem') without any issues. And since it is booting the /boot partition from the RAID without issues I figured it wasn't the case that I'm missing any critical drivers. I saw some similar results from google and when I tried to follow one in particular to run mkinitrd I am getting errors when I boot into the CentOS rescue mode that 'partition is unreadable on the disk'. I ignored those and kept booting and it seems my LVM mounts fine on it's own but nothing is visible in the /boot folder. Anyone have any good pointers on where to go from here - anyway I can rebuild the partition table without wiping anything? Remember the end-result is that I'm trying to clone this machine to another machine - if there's an easier way to do this without tracing issues I'm open for suggestions there as well (can't virtualize yet though, I still need to rebuild our virtual XenServer).


Philadelphia Linux Users Group         --        http://www.phillylinux.org
Announcements - http://lists.phillylinux.org/mailman/listinfo/plug-announce
General Discussion  --   http://lists.phillylinux.org/mailman/listinfo/plug