Conor Schaefer on 1 Aug 2010 14:25:04 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] Xen VPS & rsync

  • From: Conor Schaefer <>
  • To: "Philadelphia Linux User's Group Discussion List" <>
  • Subject: Re: [PLUG] Xen VPS & rsync
  • Date: Sun, 1 Aug 2010 17:24:57 -0400
  • Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed;; s=gamma; h=domainkey-signature:mime-version:received:received:in-reply-to :references:date:message-id:subject:from:to:content-type; bh=+lZ2op4o9Ac4IlS+LBFDKOIn7qWXowgKFIykSOJ1mj0=; b=KFxq3BN6bDkmtZf005q9oJf+i0PlArpMb7pbSWg2Rl8IdE9MuHx+kytBfgC4lf8qT2 TMtWxDvKLEfivmXIJYpkR4G0Rbkf6F1kOmsXCGU98HnzuQZqsJ7A01jIEP57LkVZ6mac AZ8KwNRfyYTY3LRTfSBJSc9TwhDJVYavMgQGU=
  • Reply-to: Philadelphia Linux User's Group Discussion List <>
  • Sender:

Solved. This is embarrassing. The syntax I should have been using, in this case, was:

rsync -e "ssh -l [linux-username]" -avP testfile [xen-username][me]/

Adding in that "xen", which I found by typing "hostname" once I was logged into the VPS, I was able to connect directly to my profile.

On Sun, Aug 1, 2010 at 2:59 PM, Conor Schaefer <> wrote:
I'm really stumped on this one. I'm in the process of moving, and so don't have a static IP to host my home server to make it remotely accessible. I've picked up a Xen VPS account (at running Ubuntu 10.04 to hold me over in the meantime, and am trying to set it up now. I'm very familiar with rsync and SSH, but I cannot for the life of me get it to play well with my new VPS.

When trying to transfer files from my laptop to the VPS via rsync, I get this output:

:~$ rsync -e "ssh -l [username]" -avP testfile [servername][me]/
sudo: sorry, you must have a tty to run sudo
protocol version mismatch -- is your shell clean?
(see the rsync man page for an explanation)
rsync error: protocol incompatibility (code 2) at compat.c(173) [sender=3.0.7]

This prompted me to read through the rsync man page, which suggests I grab output using /bin/true. I've done that, and the output I get is the Xen menu, offering me options such as create, destroy, exit, etc. Option 1 is "console," which will allow me to log in.

So when rsync is met with that shell, it aborts. How can I get around this? I've tried renaming .bashrc and .profile (so that they're not accessible), as the rsync man page suggested, but no luck there. This appears to be caused by the login process to the Xen environment, and I don't understand it well enough to know how, or whether, I can get around that initial login menu and rsync directly to the VPS.

If I can't, I don't know how much use this setup will be to me.

Philadelphia Linux Users Group         --
Announcements -
General Discussion  --