Gavin W. Burris on 28 Sep 2010 06:48:47 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] /etc/crypttab stops working on jaunty->lucid upgrade

Hi Gordon.  I remember having a similar problem.  I can't remember what
I change in the cryttab to get it working again, but here are two
working entries that do not use LUKS.

# <target name> <source device>         <key file>      <options>

backup0 /dev/disk/by-id/usb-WD_Ext_HDD_XXXX-0:0-part1 none

backup1 /dev/disk/by-id/usb-WD_External_XXXX-0:0-part1 none


On 09/25/2010 04:56 PM, Gordon Dexter wrote:
> I recently upgraded my Eee 901 from Ubuntu 9.04 to 10.04 and although
> I've loved 10.04 so far (except for the theme and buttons-on-left issue)
> this install really didn't go very well.
> As I mentioned in an earlier thread, the Eee 901 has two solid state
> disks, a 4G one for OS, and a 16G one for /home.  I have my 16G disk
> encrypted with dm-crypt, without LUKS, and in Jaunty I just made a file
> called /etc/crypttab and put the following line in it:
> crypthome    /dev/sdb1    none    cipher=aes,size=256
> That worked great in Jaunty: on boot it asked me for the password and
> mounted it, then mounted home.  All this was done automatically from the
> /etc/init.d/cryptdisks script.  If I needed to remap it I could just
> call that init script with the restart argument and it would do so.
> Now in Lucid the init script seems to have no effect.  I put the
> /etc/crypttab file there just like it was previously, but when I call
> that script nothing happens.  No error messages or anything, and I have
> no idea where log messages would be if they were enabled.
> Running the script manually doesn't work either.  The only way I can
> actually mount the encrypted volume is using the cryptsetup command
> directly, which is not exactly a feasible long-term solution.
> Anybody have any experience with this?  Last time I got similar
> results--it pretended it didn't exist until I added the
> size=256,cipher=aes and after that it worked fine.  I've added the
> hash=sha1 option, changing the cipher= option to aes-cbc-plain (which is
> what 'cryptsetup status crypthome' reports) and I've also tried adding
> the loud option, but none of those things seem to do anything.  The man
> page for crypttab hasn't been much help.  Anybody have any suggestions?
> --Gordon
> ___________________________________________________________________________
> Philadelphia Linux Users Group         --
> Announcements -
> General Discussion  --

Gavin W. Burris
Senior Systems Programmer
Information Security and Unix Systems
School of Arts and Sciences
University of Pennsylvania
Philadelphia Linux Users Group         --
Announcements -
General Discussion  --