Eric on 10 Oct 2010 09:15:34 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] Ubuntu 10.04 boot problem(s)


No fear? Ha! I ALWAYS have fear when configuring X! I will purge GDM too - that's a good idea.

Yes, a live CD is how I confirmed the absence of the files.

OpenSuse has/had a tool called SaX that worked really well but I don't know what the Ubuntu equivalent would be. More Google searches will help I'm sure.


On 10/10/2010 12:08 PM, Conor Schaefer wrote:
If you have no fear of reconfiguring settings, then a purge and install
might be the best bet for you. Notice, though, that you might want to
purge and install GDM, as well, because doing it just for X probably
won't help your /etc/gdm/custom.conf be properly generated.

You confirmed that the files were not there by mounting the partition in
a live CD environment, yes? I just ran out to pick up some blank CDs,
and I'm going to give that a spin for myself, see if I can solve this
mountall failure by adjusting fstab.

Good luck, and keep us posted!

On Sun, Oct 10, 2010 at 12:02 PM, Eric <
<>> wrote:


    I appreciate the info.

    I do not believe it's the same problem.

    There are two major clues in the /var/log/syslog file: gdm dies
    because it cannot read the /etc/gdm/custom.conf file or execute the
    /usr/bin/X file.  It says that they are not there and sure enough,
    they are not there!

    I have an Nvidia card with the proprietary driver installed but I
    did not have any problems with it through several prior reboots.

    Should I reboot without X and then use dpkg and/or apt to remove and
    then re-install X?



    On 10/10/2010 11:00 AM, Conor Schaefer wrote:

        Funny you should mention this; I've been troubleshooting a similar
        problem since last night. Take a look at this bug report and see
        if it's
        of any help to you:

        My boot process does get as far as X, but hangs there and does not
        response to keyboard or mouse input. As the bug report suggests, try
        adding a verbose flag to the kernel you're loading and see if
        you get
        more detailed output there.

        I'm grumbling because I think I'm going to have to invest in
        CD-Rs to
        rescue this system; I've tried using Unetbootin to make a
        bootable USB
        drive already, but this is unfortunately on a MacBook Pro, and the
        firmware there doesn't support booting USB drives very well. (Or so
        rEFIt reports when I try and it fails.)

        I also cannot get any virtual consoles, and the system does not
        to SSH attempts over the network. All these symptoms make sense
        if the
        primary volume isn't mounting correctly.

        Hope this helps, sorry if I've missed the mark.

        On Sun, Oct 10, 2010 at 10:48 AM, Eric <
        < <>>> wrote:

            Well, less than 2 weeks with my new 10.04 install and I'm in
            trouble... and stumped.

            It appears that X does not start or that the boot process hangs
            before it gets to X.  for a "normal" boot I end up stuck on the
            splash screen.  If I boot the "rescue" option I see:

            * Setting sensors limits  [ OK ]
            * Setting console screen modes and fonts

            ... and then it just sits there.
            I'm unable to get any virtual consoles - the screens are blank.

            I can boot the system from the old hard drive running
        Intrepid 8.10
            so I know the hardware (including video card) are fine.
              Unfortunately, I chose ext4 for the new root partition so
        I cannot
            mount it from the running Intrepid system (no support for ext4).

            I'm going to reboot from the 10.04 install disk to get a
        live system
            and see if I can gather any information from the syslog or

            [hints|tips|suggestions] would be appreciated!


Philadelphia Linux Users Group         --
Announcements -
General Discussion  --