Stephen R Guglielmo on 28 Aug 2016 20:30:29 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[PLUG] BIOS Troubles

Hey all,

I ran into an issue with my personal desktop system that I can't seem to solve: A BIOS upgrade gone wrong. This is a system I built about a year ago with an Intel Skylake processor, SSD, and a few HDDs. The main drive is the SSD with a UEFI dualboot Arch and Win10. The HDDs are btrfs raid6 (I know, I know; don't remind me) that are only used on the Arch system. It has an Asus "H170 Pro Gaming" motherboard and a Gigabyte Nvidia GeForce GTX 960 video card.

A few days ago, I noticed there was a BIOS update (in fact, there has been several released since I last updated it). I followed the instructions of downloading/unzipping the file to a FAT32 USB flash drive, booting into the BIOS/UEFI setup, and selecting the options to update it. I went through the process same as I've done in the past. It took a few minutes but was seemingly successful. Reboot. Annnnnd, blank screen.

I have since been completely unable to get to either the BIOS setup or boot from a drive.

One of two things happen:

If I boot with the FAT32 USB flash drive plugged in and/or any SATA disk attached, I get the normal "Asus - press Del for setup" splash screen, then it goes to a blank black screen. Pressing 'del' (or any other F key) doesn't make any difference.

OR, if I do NOT have a USB drive plugged in, it boots into the bios setup (even if I do not press the del or F keys) and goes to a screen that says "To complete the BIOS upgrade, please select the bios file again." Except, I'm unable to select the file because it's on the USB drive.

I've tried different USB drives. I've tried reformatting it. I've tried USB3 and USB2 ports. I've disconnected all my peripherals, disks, and even taking out the graphics card. If the USB drive is in, it gives me the blank screen. If it's not in, it asks for the file that I have no way of giving it. I've tried clearing the CMOS (by shorting the jumper), which has no affect. I've even tried another keyboard.

I really don't want to RMA it (I don't even know if it's still under warranty?) but I've really given it some effort and I've tried all the tips given in the documentation provided by Asus to no avail. Does anyone have any tips? Maybe throwing it out the window?

Philadelphia Linux Users Group         --
Announcements -
General Discussion  --