Greg Helledy on 11 Oct 2017 13:04:32 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] plug Digest, Vol 155, Issue 19

On 10/11/2017 3:00 PM, wrote:

text/plain; charset="utf-8" On 10/10/2017 08:38 PM, Greg Helledy
So my rsync backup onto non-LVM, non-RAID partitions seems to have
gone ok but I need to put a bootloader onto the drive.

I have a swap partition as /dev/sda1, /boot as /dev/sda2 and / as

for some reason I can't chroot into the /dev/sda5 partition on my
rescue cd.

If the mount point of /dev/sda5 is /root/newroot on my rescue cd,
if I'm in /root and I do chroot newroot I get: chroot:  failed to
run command /bin/zsh:  no such file or directory

(System Rescue CD may use zsh while ClearOS uses bash.  Both the
rescue CD and my OS are 64-bit).

Is there any way around this, or any way to create a boot record
by entering information about the partitions?

first things first, have you tried:

chroot /mnt/newroot /bin/bash

That works if I boot into the root directory--thank you!  Then I run
into the frustrating problem that it doesn't help me because there's a
separate boot partition, and boot is what I need access to to update
grub.  If I try the same command to chroot into the boot partition,
unsurprisingly it doesn't work:
chroot:  failed to run command /bin/bash:  no such file or directory

If I'd had the entire filesystem on one partition, I'd be all set at
this point, but because of the separate boot partition it doesn't work.
 Is there a way around that?


secondly, is it BIOS/MBR, BIOS/GPT, or UEFI/GPT?


Parted Magic and others can copy partitions and/ or entire disks from
LVM.  I've used this to backup my lvm encrypted laptop disk prior to
So that's what I should have used.  A painful lesson.  I actually went
to start with Clonezilla but wasn't sure how best to answer some of the
questions it asked, and when a co-worker suggested Paragon I tried it.

You can copy the /etc/lvm path which takes before and after captures
of LVM changes so that you can restore a configuration is need be.
You can review the man page for "vgcfgretore" and the documentation

 However between Linux systems the LVM configuration (metadata) is
automatically detected and used (and usually then place into
/etc/lvm). Is the source system LVM only or LVM + MD RAID?


Thank you for the info on LVM, I think it's too late for me at this
point, it looks like some of the LVM-related info on the disk has been
"touched" by Paragon.  I can still mount partitions manually but neither
RAID disk will boot.

Next I'm going to try reinstalling the OS, this time NOT using LVM, and rsync-ing the files over.

Greg Helledy
GRA, Incorporated
P:  +1 215-884-7500
F:  +1 215-884-1385
Philadelphia Linux Users Group         --
Announcements -
General Discussion  --