jeffv via plug on 28 Jun 2020 09:30:55 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] Grub

I discovered the system partition hosed, albeit still a partition. Have to reinstall after i play Swap the Partitions. If i let myself think about this, i will be very agitated.

I have to sage my house AND my computer.

Thanks for the suggestion.

On June 27, 2020 8:55:39 PM EDT, "Keith C. Perry via plug" <> wrote:

To fix boot issues, the best thing to do is to boot from a live cd or usb. From there you can mount the file system and chroot so you can fix it, for example...

(Apologies... I'm doing this from memory since I can't find the last time I posted this on PLUG but this should get you started)

This assumes, sda is the drive in question. Depending on how the live system boots it could be something else so do an "lsblk" or "blkid" to find the right disk...

mount /dev/sda1 /mnt
for dir in proc sys dev; do mount --bind /$dir /mnt/$dir; done
chroot /mnt
grub-install /dev/sda (I forget the exact parameter there for EFI but I've done this with DOS and EFI disk maps)

The update-grub should find everything including your windows partitions and then grub-install will install the boot code. You can now reboot system.

I haven't dual booted a system in a long time (and it wasn't using EFI) but I don't see why this wouldn't work.

~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~
Keith C. Perry, MS E.E.
Managing Member, DAO Technologies LLC
(O) +1.215.525.4165 x2033
(M) +1.215.432.5167

----- Original Message -----
From: "jeffv via plug" <>
Cc: "Philadelphia Linux User's Group Discussion List" <>
Sent: Saturday, June 27, 2020 6:13:01 PM
Subject: Re: [PLUG] Grub

On June 27, 2020 8:52:45 AM EDT, Joe Rosato <> wrote:
Have used this tool many times before to fix weird boot issues.

The boot mgr was on the first live disc, but I'll give this a shot. Thanks.

I picked the wrong day to stop sniffing markers.

Also, if using EFI, try this boot manager. Just looks and reports back the
options out there.. less a repair and more a way to easily get into
anything EFI

That's my 10 cents!


On Fri, Jun 26, 2020, 9:58 PM jeffv via plug <>

Bit of a problem

Sda: (dual boot)
Sda1: tiny partition. Ntfs
Sda2: win. Ntfs
Sda3: lin. Ext4

Sdb Ext4, i think
All Extended

Sdb installed recently. When i removed it, I got the grub prompt. I sure
didn't put boot files on it.

After boot rescue i can get into win. There's a choice for lin but it goes
right to grub. When i do 'ls', instead of the drives, i get a list of win

I also tried rescatux, with no luck. When it tried to correct things there
was an error installing grub, but i didn't have a need to know what it was.

I've done all sorts of research, but it doesn't apply or work. It seems
like it should be so easy, as there's a choice of which to boot. I have to
hook sda3 to the lin side of the boot choice. It's just not working out or
i goofed

Ideas welcome.

Sent from my non
Philadelphia Linux Users Group --
Announcements -
General Discussion --

Sent from my non iDevice
Philadelphia Linux Users Group         --
Announcements -
General Discussion  --