Michael C. Toren on Sun, 8 Jun 2003 22:57:06 -0400

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [tcptra-dev] tcptraceroute test suite

> >Oops, you're right.  This one-line fix should correct the problem:
> That worked fine.. weird thing that it worked under Linux. I could not
> find the perldocs for sockaddr_in, I guess you did. :-)

The perl function is provided by the Socket.pm module, which is why
something like "perldoc -f" isn't very helpful in this case.

> This result is the same with 1.4 and 1.5beta3. Everythings looks ok 
> except for the last line. As far as I know Solaris does not have a 
> device in /dev for loopback (and if it did, it would be called /dev/lo 
> not /dev/lo0).
> > It might also be interesting to see if the error is also present with
> > libnet-1.1.x.
> Now with libnet 1.1.1 (1.1.0 does not work on Solaris):
> I don't see how this is a libnet problem. tcptraceroute does:

I had a (perhaps irrational) hope that libnet-1.1.x might solve the
problem, only because I happened to notice that the changelog entry for
libnet-1.1.1 mentions improved loopback support.  Oh, well; thanks for

> device here is /dev/lo0 ... I am not sure if this is a pcap issue or 
> that we need to be smarter about which device to use for localhost on 
> Solaris.

That very well could be, and should be easy enough to determine.  The
debugging output you pasted earlier revealed that three interfaces were
found in addition to the loopback:

> debug: Discovered interface lo0 with address
> debug: Discovered interface eri0 with address
> debug: Discovered interface hme0 with address
> debug: Discovered interface sppp0 with address

Are you able to successfully traceroute to either or if you specify the device to use by hand?

	tcptraceroute -d --no-filter -i eri0
	tcptraceroute -d --no-filter -i hme0
	tcptraceroute -d --no-filter -i sppp0

	tcptraceroute -d --no-filter -i eri0
	tcptraceroute -d --no-filter -i hme0
	tcptraceroute -d --no-filter -i sppp0

Another test to help determine if it's a libpcap problem might be to
see if tcpdump can attach to the loopback interface.  Something like:

	tcpdump -n -i lo0

tcptraceroute-dev mailing list