[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Umbunto Not Updating & Firefox Not Working

Okay, and ... try again ... and should be able to reinstall that
LibreOffice stuff easily enough:

So, ... let's try again ...
I tweaked the configuration a bit ...
# virt-install --name=ubuntu-14.04.4-desktop-amd64 \
--cdrom=/var/tmp/ISOs/ubuntu-14.04.4-desktop-amd64.iso --nodisks \
--livecd --network=network=default --ram=2048 --wait=-1 \
--os-type=linux --os-variant=ubuntusaucy --virt-type kvm --hvm

Then on the virtual machine console, with Ubuntu's cryptic icon thingy
which apparently is their way of saying in 847 language to hit a key if
you want to configure boot parameters/options, etc., I hit space, and ...

proceeded to tweak some kernel parameters for boot:
I removed these boot parameters:
quiet splash
and added these:
consoleblank=0 console=tty0 console=ttyS0,9600n8
with the above dropping quiet mode (so I get more verbose - especially
useful should the boot fail anywhere along the way), drop splash (don't
need no steenkin' splash image), don't want the console to blank after
some seconds of inactivity (it's virtual anyway, so I don't have any
reason to want it to blank), and I added serial port as secondary
console - leaving tty0 as primary (the default) - that gives input from
primary, and output to booth.  I'm only bothering to do that, as, with
virtual, it can be very handy to use serial console - so I at least
enable that.

hit <Enter> to boot ...
Ew ... graphics ... whatever.
Let's see ... Ewey GUI way to deal with purge/reinstall Libre Office?
Let's dismiss that default Keyboard Shortcuts overlay thingy it gives me
by clicking on the X ...
Now I have to guess what all those icon thingies are.
I scroll the mouse over the ones on the left,
they display some text ... one of 'em says "Ubuntu Software Center" -
that sounds promising ... I click it ... on left it says "Office" - that
sounds promising - I click it ...
There's a scroll thingy on the right ... but it's kind'a difficult to
pick/select and scroll with it ... whatever, I more-or-less manage ...
I see some LibreOffice stuff, notably LibreOffice and LibreOffice Writer
... no idea if they're installed, or it's offering to install 'em.  Oh,
I notice in upper-right "By Top Rated", with a little drop-down lookin'
arrow thingy ...
I click that arrow thingy ... I select By Name ... now I scroll again ...
Uhm, ... they must have a weird way of sorting by name ...
Orage Globaltime
Labyrinth Mind-mapping
Getting Things GNOME!
... oh well, so much for a useful sort order.
There's a search thingy in upper right,
I type in: LibreOffice
... that seems to work - mostly filters it down to LibreOffice stuff
(and also "Extra Office Applications" ... which does also mention
libreoffice, along with a lot of non-LibreOffice stuff).
So ... how to purge via GUI?  I dunno.  Not an Ubuntu expert.
I click on LibreOffice ... it offers me a "More Info" button - I click
that ... "Not found There isn't a software package called libreoffice in
your current software sources." - well that's pretty useless.
Oh, at top, there's an "Installed" icon ... I click that ...
then I click "Office" on left side ... it shows me three LibreOffice
thingies in (apparently/presumably) installed state (and lil' green
checkmarks on 'em).

Okay, so I click the first one:
LibreOffice Impress
it offers me two buttons - "More Info" and "Remove" (but no "purge"
Okay, whatever, I click "Remove" ... "To remove" ... "these items must
be removed as well:" ... I click "Remove All" ...
I proceed likewise with:
LibreOffice Math
LibreOffice Writer
LibreOffice Calc
... okay, it no longer shows me any of that LibreOffice stuff under
"Office".  And ... to *purge* 'em? ... I dunno ... Ubuntu GUI?  STFW ...
seems like Synaptic may be the GUI way to do it?
I click the Ubuntu lookin' logo thingy in upper left ...
I type in "Synaptic" in the search thingy ...
"Sorry, there is nothing" ...
Screw it I'm gonna "cheat" and use the wonderful CLI ...
but need to enable login on the serial, so ...
first I jump to the first virtual terminal tty1 (which is CLI),
//I'll show my comments on lines starting with //
ubuntu@ubuntu:~$ cd / && exec sudo su -
root@ubuntu:~# PS1='# '
# cd /etc/init
# cp -p tty1.conf ttyS0.conf
# sed -e 's/tty1/ttyS0/g' < tty1.conf > ttyS0.conf
# start ttyS0
ttyS0 start/running, process 4668
//Now we're cookin' with gas.  ;-)

//From my the host, I connect to the serial console of the virtual
# virsh console ubuntu-14.04.4-desktop-amd64
Connected to domain ubuntu-14.04.4-desktop-amd64
Escape character is ^]

ubuntu@ubuntu:~$ cd / && exec sudo su -
root@ubuntu:~# PS1='# '
//So now I look for packages that aren't fully installed:
# dpkg -l | grep -v '^ii'
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
rc libreoffice-calc 1:4.2.8-0ubuntu4 amd64 office productivity suite -- spreadsheet rc libreoffice-impress 1:4.2.8-0ubuntu4 amd64 office productivity suite -- presentation rc libreoffice-math 1:4.2.8-0ubuntu4 amd64 office productivity suite -- equation editor rc libreoffice-writer 1:4.2.8-0ubuntu4 amd64 office productivity suite -- word processor
//So, do they give us apt-get, or aptitude, or ???
# type apt-get
apt-get is /usr/bin/apt-get
# type aptitude
-su: type: aptitude: not found
//From that I'm going to presume apt-get is preferable over aptitude ...
//which is perfectly fine with me, as it's also my preference.
//So, let's purge those remnant bits (the rc indicates removed except
//configuration files remain).
# apt-get -y purge $(dpkg -l | awk '{if($1=="rc")print $2;}')
//that bit above purges all configurations of all removed packages,
//if that's not what you want, just explicity give the names of the
//packages you want to purge, e.g.:
//# apt-get -y purge libreoffice-... ...
# dpkg -l | grep -v '^ii'
//and I find no packages that aren't in ii (fully installed) state.
//... now to reinstall the removed packages.
//... well, first, index of available versions is probably quite
//out-of-date, so, first I do:
# apt-get update
//... I have a peek using apt-cache search, to see if there's a (meta)
//package that would pull in all, or most all, of LibreOffice ... there
//might be one, but I'm not easily spotting it.  Maybe I can find it
//via apt-cache's rdepends ... libreoffice-core sounds promising ...
//yeah, looks like that would do it - but probably lots more than I
//want to drag in ... but I was curious.  And it did show in the
//earlier search I did, but I probably skimmed it bit too fast ... saw
//-base, but that was for database ... was expecting to see a bare
//"libreoffice" packages or such, but didn't spot that.  Anyway, let's
//just reinstall what I removed/purged ... and any dependencies thereof
//... but with current versions since I did the apt-get udpate.  Let's
//find the names again - since some I removed via GUI ... could look in
//logs, but, naw, likely can get 'em all well enough from names and bit
//'o search (and this ain't production, so I'm not too worried if I
//don't get it exactly right ... heck, it's just live version on a
//virtual machine) ...
//So, earlier from GUI, it was these I removed:
//LibreOffice Impress
//LibreOffice Math
//LibreOffice Writer
//LibreOffice Calc
//and from CLI, it was these I purged:
//So looks like the names probably match up very nicely,
//so I'll simply install those with apt-get - and that will also bring
//in any dependencies:
//I specify them in the reverse of the order I removed them - just in
//case that might matter:
# apt-get -y install libreoffice-calc libreoffice-writer \
libreoffice-math libreoffice-impress
//And I can check that I have 'em installed now:
# dpkg -l libreoffice\* | grep '^ii' | awk '{print $2;}'
//Likely works fine now, but whatever, enough, I'm done with it.
//Were it an installation I actually cared about, I would've also done:
//# apt-get upgrade
//but since this was never installed (just "live"), and never given a
//routeable Internet IP address, I'm not particularly concerned about
//its security, and am about to "throw it away" anyway.  Could shut
//down properly, but ... nothin' to save, so don't care.  Just jump back
//to the host, and:
# virsh destroy ubuntu-14.04.4-desktop-amd64
Domain ubuntu-14.04.4-desktop-amd64 destroyed

# virsh undefine ubuntu-14.04.4-desktop-amd64
Domain ubuntu-14.04.4-desktop-amd64 has been undefined


So ... did anyone spot my earlier booboo on why it didn't boot?
I'd intended to bump the RAM on the virtual machine up from my
default I use of 1 GiB, to 3 GiB ... so any bloat of LibreOffice would
likely fit reasonably comfortably within the RAM used for filesystem
writes ... but in my haste, I had:
rather than an intended 3 GiB (MiB=3072), so, yeah, no surprise the boot
loader didn't get very far at all.  I later set it to MiB=2048 which was
more than sufficient.

Disclaimer: not an Ubuntu person

From: "Michael Paoli" <Michael.Paoli@cal.berkeley.edu>
Subject: Re: Umbunto Not Updating & Firefox Not Working
Date: Tue, 13 Sep 2016 07:52:08 -0700

From: "Michael Paoli" <Michael.Paoli@cal.berkeley.edu>
Subject: Re: Umbunto Not Updating & Firefox Not Working
Date: Mon, 12 Sep 2016 22:31:42 -0700

bit different
for Unbuntu from CLI - perhaps Ubuntu expert will chime in to address that.

So ...
not an Ubuntu expert, so ... let's see ...
Ubuntu ... 14.*4*, I'll presume 14.04.4 (should cover well enough
for 14.04[.x]).  You didn't mention "32 bit" (i386) or "64 bit" (amd64),
so, I'll go with i386 (should be quite similar to amd64, other than the
architecture difference).  You didn't mention server, so I'll presume

Let's fire up ubuntu-14.04.4-desktop-i386 (virtually, from my Debian
stable) ...
# virt-install --name=ubuntu-14.04.4-desktop-i386 \
--cdrom=/var/tmp/ISOs/ubuntu-14.04.4-desktop-i386.iso --nodisks \
--livecd --network=network=default --ram=3 --wait=-1 \
--os-type=linux --os-variant=ubuntusaucy --virt-type kvm --hvm
(yes, I have a TEMPLATE file I copy and edit, which then executes that
Error setting up gfxboot
STFW (Search The Fine Web) ...
Just type help and press Enter. It will continue to boot normally.
Not enough memory to load specified image.
<F1>...<F7>... various stuff tried, still no successful boot
Hmmmm, whatever, let's try different Ubuntu 14.*4* image:
# virt-install --name=ubuntu-14.04-desktop-amd64 \
--cdrom=/var/tmp/ISOs/ubuntu-14.04-desktop-amd64.iso --nodisks \
--livecd --network=network=default --ram=3 --noreboot --wait=-1 \
--os-type=linux --os-variant=ubuntusaucy --virt-type kvm --hvm
Error setting up gfxboot
enough 'o my time and (3 GiB of) RAM ... I'll leave it to some
Ubuntu person.

You received this message because you are subscribed to the Google Groups "BerkeleyLUG" group.
To unsubscribe from this group and stop receiving emails from it, send an email to berkeleylug+unsubscribe@googlegroups.com.
To post to this group, send email to berkeleylug@googlegroups.com.
Visit this group at https://groups.google.com/group/berkeleylug.
For more options, visit https://groups.google.com/d/optout.