Jason on Thu, 11 Jul 2002 16:23:26 -0400

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] LILO weirdness

Hash: SHA1

On Thursday 11 July 2002 15H:09, Greg Lopp wrote:
> After some swaping in and out of ide HDs a few days ago, which
> ended with a return to my original HW config, I am no longer able
> to boot into win98.  After the LILO menu, it says "Non-system

I am tempted to ask, "Is this a bad thing?". But, I'll try to be nice.

> disk error", etc.  Booting linux has not been effected.
> rough summation :
> lilo.conf
> boot=/dev/hda
> root=/dev/hda5
> image=/vmlinuz
>         label=Linux
>         read-only
> #       restricted
>         alias=1
> other=/dev/hda1
>         label=Win98
>         alias=2
> Any clues or pointers?

You created a "Win98 Rescue Disk", right? If so, have you tried that?

Assuming you haven't or that it hasn't helped:

I've seen this sort of thing happen under WinME. Win 95/98/ME seems to be 
particularly sensitive to changing which partition is marked as "Active" in 
the partition table. Didn't dig into the problem to see why.

Under Win98, you ought to be able to boot to a dos system disk. I would verify 
that the Win98 partition looks good there.

If so, and nobody has a better suggestion, you might try doing a "sys c:". 
That should transfer the basic DOS boot files to your C: drive without 
erasing any data (You might try this with the DOS system files installed 
under the Windows directory - I think, I forget where). If that works, you 
ought to at least be able to boot to the C: drive. From there, you should be 
able to repair the Win98 installation. I forget some of the details. Haven't 
worked with Win98/ME very extensively for a while.

Jason Nocks
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org


Philadelphia Linux Users Group       -      http://www.phillylinux.org
General Discussion  -  http://lists.phillylinux.org/mail/listinfo/plug