Art Alexion on 16 Sep 2008 12:32:34 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] removing an unconfigured deb - RESOLVED

On Friday 12 September 2008 7:17:17 pm David A. Harding wrote:
> On Fri, Sep 12, 2008 at 10:12:11AM -0400, Art Alexion wrote:
> > kqemu-sources was not removed as a dependency and it is still trying
> > to configure.
> The following command should tell the package system to put itself in a
> consistent state:
> 	apt-get -f install
> The -f stands for fix.  It might suggest something you don't want --
> like installing all the packages you just removed.  If you can't or
> won't do what it says, we can try running some dangerous forcing
> commands.
> However, if it doesn't work, please send along anything significant it
> says and the output of the following command:
> 	dpkg -l kqemu-sources

Coincidence or typo, that is the question!

OK, so I ran 
sudo aptitude purge kqemu-sources
no go.

So I ran 
sudo aptitude -f install
no go.

So I ran
sudo dpkg -l kqemu-source
and the package was shown installed but not configured.

Sent the results to Dave.  Meanwhile I ran
sudo aptitude remove kqemu-source
This time it removed the package and two no longer used dependencies.

Either there was some weird difference between remove and purge (unlikely), or 
I misspelled kqemu-source (probably).  Since I used the up arrow for 
variations of things I was trying, I probably repeated the typo.  I going to 
guess quemu instead of qemu.

Thanks, and never mind....

Attachment: signature.asc
Description: This is a digitally signed message part.

Philadelphia Linux Users Group         --
Announcements -
General Discussion  --