brent timothy saner on 17 Aug 2010 22:47:51 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] X11 server for Windows

  • From: brent timothy saner <>
  • To: Philadelphia Linux User's Group Discussion List <>
  • Subject: Re: [PLUG] X11 server for Windows
  • Date: Wed, 18 Aug 2010 00:47:40 -0500
  • Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed;; s=gamma; h=domainkey-signature:received:received:message-id:date:from :user-agent:mime-version:to:subject:references:in-reply-to :x-enigmail-version:content-type:content-transfer-encoding; bh=nqceLUkgdfZRf3OnrWqWdMuiQ/3DWxEkcpf8LbFxOwY=; b=vS62iHJJ9bu3czyLZ1kn6jGYsSCFoND+UXWBRenobpXtfB4ToH2NT+X2nCfnkzxXUz h7q9lf/GLKsRn9YhKOHvaA6FzwNDekF/cNfx2FQCoHVpfyauVaGjNb98Pn0bgMBzhLOn VkVt04D/PcZUXBzkZizArdhf5naikLNVvX+e4=
  • Reply-to: Philadelphia Linux User's Group Discussion List <>
  • Sender:
  • User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20100809 Lightning/1.0b2pre Thunderbird/3.1.2

Hash: SHA1

On 08/17/10 17:26, JP Vossen wrote:
> Short version: I just found and liked this trivial freeware X11 server
> for Windows:
> *
> --> Mocha_XServer-2.0.exe
> Long version:
> I needed to install Oracle 11G on CentOS the other day.  (Have I
> mentioned that I loath Oracle with a passion?)  Among many other
> problems, the *installer* requires a *GUI*.  WTH?!?  A GUI does not
> belong on a server, so why do you require one to install your arcane PoS
> "server" software?!?  Drives me insane.
> So I crufted up my VM with "yum groupinstall 'X Window System'" which
> inflicted another 197 packages with a *download* size of 84M on my
> server.  Then it bitched about lack of RAM, SWAP, and various kernel
> parameters.
> After a whole bunch more pain, I finally got almost to the point I
> needed to be.  Except...  I can only connect to the server over the VPN,
> and the VPN is on my WinXP box only.  So 'ssh -X' was problematic.
> I googled around for X11 server for Windows and came up with the usual
> suspects.  This one worked out really well.  I installed it, and ran it
> and it Just Worked.  (I actually used SecureCRT's version of -X, but
> there's no reason PuTTY shouldn't work too.)
> *
> --> Mocha_XServer-2.0.exe
> And yes, I know about the Oracle Express RPMs, for various reasons I
> couldn't use them in this case.  I have used them in the past and they
> sucked a bit less, but still whined a lot about  RAM, SWAP, and various
> kernel parameters.  At least no GUI was needed for an 'rpm -Uvh *.rpm'.

just for future reference, there's also Cygwin/X which i've used with
little to no fuss back when i was on a windows box.
quick little write-up here:
Version: GnuPG v2.0.16 (GNU/Linux)
Comment: Using GnuPG with Mozilla -

Philadelphia Linux Users Group         --
Announcements -
General Discussion  --