Randall A Sindlinger on 22 Apr 2011 08:50:20 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] Network shares

On Thu, Apr 21, 2011 at 11:32:22PM -0400, Eric H. Johnson wrote:
> Doug,
> True, but I have both NFS and SMB enabled and tried both.
> I did just have some success however. I created a folder 'music' off root
> and managed an nfs share to it. I just cannot seem to figure out how to do a
> share to anywhere else. I was not able to do a share to /home/mythuser/music
> for example.

This takes things back to your initial post...

> > And now trying the same thing with:
> > sudo mount -t nfs -o vers=3 /music
> >
> > Both of these commands now yields the error "mount point /videos [or /music]
> > does not exist".

The nfs share to the "folder 'music' off root" worked because that's exactly
where you're telling it to mount it.

> > I have never really understood network shares in Linux, particularly the
> > pathing. I am trying to map the MythTV music folder from the back end to the
> > front end. The path on both the backend and frontend is:
> > /var/lib/mythtv/music
> >
> > Can anyone explain this to me?

In Linux, network shares are just another rendition of mounting, and if I'm 
understanding you correctly, it seems the whole in your knowledge is really
in mounting and mount points.

The basic abstract of it is just "mount what where", eg,
   mount $options /music
(I'm just abstracting the specific options out to a supposed environment
variable, because that's not really what's important here)

The "what" is "" - presumably your backend
machine has the .240 IP address, and the absolute path you want to access there
is /var/lib/mythtv/music.

The "where" is "/music" - that's an (absolute) path to a location on your local
machine (ie, localhost).  Just as I can't tell you to put the delivered flowers
into a vase without telling you where the vase is, you can't mount something
to a location that doesn't exist (forgive me if you know this already).  So, in
your recent success, you created the absolute path /music.  Now that it exists,
you can (figuratively) "put" the remote data there.

When the command failed originally, there was no absolute path /music.  So the
error message said "Vase?  What vase?  I don't see any vase."  What it failed
to make painfully obvious was that it was looking for the vase right inside the
front door, because that's where you told it to start looking.  Now I'm guessing 
your working directory when you executed the command was /var/lib/mythtv on
the local machine.  But the "where" you gave was _absolute_, not relative -
that is, you told it to look for "/music", not "music".  If you start the "where"
with a slash, you're promising to give it the full path, so you need to type
"/var/lib/mythtv/music" as the "where".

I'm really hoping that I inferred correctly the source of the issue here;
otherwise, everything I wrote probably ends up just sounding pompous =8-0

Philadelphia Linux Users Group         --        http://www.phillylinux.org
Announcements - http://lists.phillylinux.org/mailman/listinfo/plug-announce
General Discussion  --   http://lists.phillylinux.org/mailman/listinfo/plug