Eric at on 20 Aug 2011 16:17:24 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] Debian unstable locking up and corrupting filesystem

Hash: SHA1

Have you tried ctr-atl-backspace?

That will kill off the X server IF the keyboard is responding.
Alan's suggestion of ssh-ing to the system is good too.  These help to identify
if the problem is just the X server and/or video or if it's deeper than that.


On 08/20/2011 02:34 PM, David B. van Balen wrote:
> I've been having a recurring problem the past few weeks where my system will
> suddenly lock up. If this happens while I'm at the computer, I'll be able to
> move the mouse pointer around, but none of the apps will respond. If it happens
> when I'm not around, I'll come back to a blank screen and the computer won't
> respond at all. In all cases, there's nothing to do other than a hard reboot,
> after which ext3 says it can't replay the journal and I'll have various
> filesystem issues until I run an fsck. It happened again yesterday, and now the
> system won't boot.After the grub menu, I get a bunch of stuff like:
> [   13.720864] ata1.00: status: { DRDY ERR }
> [   13.720905] ata1.00: error: {UNC }
> [   13.744497] end_request: I/O error, dev sda, secdtor 195523
> followed by messages about not being able to mount /dev, /sys and /proc because
> there's "No such file or directory" and I'll get dumped at a BusyBox prompt
> (when I type "help" I don't see an option to run fsck, so I'll have to see if I
> can figure out another way to run it).
> In any case, I think this started happening shortly after Debian started
> packaging my ati firmware drivers in non-free, or some such. I had been getting
> errors at startup about not being able to load some firmware files, so I finally
> installed the appropriate packages about a week ago and got rid of the firmware
> error on startup. I figured that would fix the issue, but obviously that wasn't
> the case.
> Does anyone have any ideas as to what might be causing this? It's becoming very
> annoying. Other than the firmware thing, the only significant change I can think
> of happening recently is that my kernel got swapped out for a -pae kernel (I
> have a 64 bit AMD processor that I'm running a 32 bit OS on), and the kernel was
> also upgraded to 3.0 recently, but I think I might've been having this issue
> before that upgrade.
> ___________________________________________________________________________
> Philadelphia Linux Users Group         --
> Announcements -
> General Discussion  --

- -- 
#  Eric Lucas
#                "Oh, I have slipped the surly bond of earth
#                 And danced the skies on laughter-silvered wings...
#                                        -- John Gillespie Magee Jr
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla -

Philadelphia Linux Users Group         --
Announcements -
General Discussion  --