Art Alexion on 12 Feb 2012 06:38:23 -0800

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[PLUG] Gremlins in the Machine

Gremlins in the Machine, or maybe there wasn't enough dust on it before.

As a promise to a co-worker, and because I needed some stuff off of the machine, I decided to fix my Linux desktop which hadn't been booted since the summer of 2010.  A kernel and/or grub update that summer mis-identified the boot drive so grub kept failing.  I could't get to the raw files with a boot CD because I had put "/" on an LV and wasn't familiar enough with LVM to manually mount the LV volume.  I had a Mac Mini which I was using for the sole purpose of managing an iPod, and got lazy and just started using that.  I tried a few dozen times to fix the boot problem before giving up, googled LVM and found stuff I never bothered trying.  The abandoned computer was another example of the dentist who's kids have rotten teeth, the lawyer without a will and the cobbler with barefoot kids.

So today, I boot with knoppix and check out the menu.lst file and backup.  I ran a diff and the main file and backup were the same.  So I tried to boot the HD again just to refresh my memory on the error.  It just booted fine.  Just fine.  Not only that, but the disk activity light — which never worked — now works.  Maybe this thing just wasn't dusty enough. Maybe it had been too pampered and now just craved attention.

Thanks for indulging my rant.
Philadelphia Linux Users Group         --
Announcements -
General Discussion  --