Walt Mankowski via plug on 3 Jan 2022 07:10:31 -0800

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] Very weird error with make (constant segfaulting)

On Mon, Jan 03, 2022 at 09:11:29AM -0500, Lynn Bradshaw via plug wrote:
> So I was about to start compiling some software project and make
> segfaulted. I thought it might have been a fluke, so I tried again,
> same thing, repeatedly. Tried backing out of the shell or tmux
> altogether, restarting the terminal emulator, using bash (normal
> choice is zsh on this one) and ultimately only restarting the entire
> machine fixed it.
> I don't think it's dodgy hardware because a) only make has ever done
> this (I think it's the second or third time now) and b) the hardware
> in question is reasonably new and also c) the uptime that of course
> got wiped out was nearly three weeks. The one hardware possibility
> that comes to mind is that it's a Raspberry Pi (four cores, ARMv7
> Processor rev 3 (v7l)) and something just slipped under the radar that
> maybe wouldn't have if it had been an Intel or Intel-like processor.
> "Nuke it from orbit" is generally bad practice but yeah. I've never
> seen anything else quite like it. Anyone who's experienced anything
> remotely of the sort and it got fixed somehow, please let the list
> know.

Does it happen every time you run make, or just with specific
projects? I've attached a very simple c file and Makefile. What
happens when you run `make hello`?


Attachment: signature.asc
Description: PGP signature

Philadelphia Linux Users Group         --        http://www.phillylinux.org
Announcements - http://lists.phillylinux.org/mailman/listinfo/plug-announce
General Discussion  --   http://lists.phillylinux.org/mailman/listinfo/plug