eric on Tue, 04 Mar 2003 11:01:07 -0500

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[PLUG] CDROM making me crazy


I've tried everything I can think of to fix this and _still_, I get 
the following message when I try to mount the cdrom device:

mount /mnt/cdrom
mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
       or too many mounted file systems
       (could this be the IDE device where you in fact use
       ide-scsi so that sr0 or sda or so is needed?)

Here are the details:
  Machine:  Pentium box, SCSI HD (NO IDE drive) Teac CDROM on 
            secondary IDE as Master (/dev/hdc).  Have tried two
            different CDROM drives and two different cables.
            The BIOS can identify the CDROM on boot so it appears
            to be connected properly.  We cannot move it to the 
            primary IDE or it will conflict with the boot-up of
            the SCSI drive :-(

  OS:  e-smith 5.6 (based on Red Hat 7.3 IIRC)


We had a working box (don't most vexing problems start out
this way?) and we went to install a Travan tape drive on the 
secondary IDE as a slave device.  When we booted the bios would not
see either the CDROM or the tape drive.  We tried switching the master
and slave relationships and there was no change.  

We decided that the travan tape drive was bad and went back
to the SCCI DDS-3 drive that was there before (don't ask :-P )

Now, the BIOS sees the CDROM, the OS appears to see the CDROM
(it's in dmesg like this:  "hdc: CD-532E, ATAPI CD/DVD-ROM drive")
but no CD-ROM can be mounted.  I know that it's not on hda|hdb|hdd
since I get the "not a valid block device" message.  We've tried 
several CD-ROMs - factory and CDR's with identical results.

Anybody have any ideas?  I suspected that one of the times I booted
the box with the Travan installed that the kernel must have changed
something but I have no idea how or why it would do that or how that
could influence the subsequent boots.

Here, by the way, are the commands I tried as well as the 
contents of fstab and mtab:

mount /mnt/cdrom
mount -t iso9660 /dev/cdrom /mnt/cdrom
mount -t iso9660 /dev/hdc /mnt/cdrom
mount -t iso9660 -t ro /dev/hdc /mnt/cdrom

Yes, /mnt/cdrom exists and /dev/cdrom -> hdc
(should that be /dev/cdrom -> /dev/hdc ?)

# BE CAREFUL WHEN MODIFYING THIS FILE! It is updated automatically
# by the SME server software. A few entries are updated during
# the template processing of the file and white space is removed,
# but otherwise changes to the file are preserved.
# For more information, see and
# the template fragments in /etc/e-smith/templates/etc/modules.conf/.
# copyright (C) 2002 Mitel Networks Corporation
LABEL=/                 /                       ext3    usrquota,grpquota 1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
/dev/cdrom              /mnt/cdrom              iso9660 noauto,owner,ro 0 0
/dev/fd0                /mnt/floppy             auto    noauto,owner    0 0
none                    /proc                   proc    defaults        0 0
none                    /dev/shm                tmpfs   defaults        0 0
none                    /dev/pts                devpts  gid=5,mode=620  0 0
/dev/sda5               swap                    swap    defaults        0 0
/dev/sda3               /home/e-smith/files     ext3    usrquota,grpquota 1 1 

/dev/sda6 / ext3 rw,usrquota,grpquota 0 0
none /proc proc rw 0 0
/dev/sda1 /boot ext3 rw 0 0
none /dev/shm tmpfs rw 0 0
none /dev/pts devpts rw,gid=5,mode=620 0 0
/dev/sda3 /home/e-smith/files ext3 rw,usrquota,grpquota 0 0 

At this point my balding head is balder and it's starting to ache...
a LOT!

TIA for any suggestions/ideas you can offer.

Eric Lucas

"Birds fly - men drink"
  -- Toast on the anniversary of the Wright Brother's
      first flight in 1903.

Philadelphia Linux Users Group        --
Announcements -
General Discussion  --