Mark Dominus on 12 Aug 2005 06:20:02 -0000

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[PLUG] Mouse puzzle

I have several mice, which I will call mouse A, B1, B2, and B3. B1,
B2, and B3 all behave the same, so I will refer to B1, B2, and B3
collectively as "mouse B".  Mouse A is different.  The largest and
most obvious difference is that mouse A works and mouse B does not.
For various reasons, I would like to throw away mouse A and use mouse
B instead, except that I also want mouse B to work.

All the mice are serial mice with round 6-pin plugs.  My computer's
serial socket is the trapezoidal 9-pin kind, so I have an adapter plug
in between.

I don't think there is a problem with the mouse protocol
configuration; I think the problem is at a lower level.  Here is why.
I kill off all the software that is using the mouse.  Then I run a
small program that just reads the serial device, /dev/ttyS1 in this

With mouse A, the little data dumping program dumps out a reassuring
stream of data whenever I move the mouse or click the buttons.  But if
I unplug mouse A and plug in mouse B instead, the little program dumps
out nothing.  When I plug mouse A back in, the program dumps out data

The serial port is set as follows:

        speed 1200 baud; rows 0; columns 0; line = 0;
        intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = <undef>;
        eol2 = <undef>; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R; werase = ^W;
        lnext = ^V; flush = ^O; min = 1; time = 5;
        -parenb -parodd cs8 -hupcl -cstopb cread clocal -crtscts
        ignbrk -brkint ignpar -parmrk -inpck -istrip -inlcr -igncr -icrnl -ixon -ixoff
        -iuclc -ixany -imaxbel
        -opost -olcuc -ocrnl -onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0
        -isig -icanon -iexten -echo -echoe -echok -echonl -noflsh -xcase -tostop
        -echoprt -echoctl -echoke

which I think is as it should be.  I have tried setting it to
different baud rates to see if I got better results, but I did not.
At different baud rates the dumper program continued to dump data for
mouse A (although it looked as though some data was being dropped, as
one would expect) and nothing at all for mouse B.

If I run

        kudzu -p

to probe the hardware configuration, it finds

        class: MOUSE
        bus: SERIAL
        detached: 0
        device: ttyS1
        driver: generic
        desc: "Generic Serial Mouse"

when mouse A is plugged in, and nothing when mouse B is plugged in.

Does anyone have any suggestions for what I might try next?

Philadelphia Linux Users Group         --
Announcements -
General Discussion  --