Art Alexion on 29 Aug 2005 16:28:30 -0000

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] Connecting a Mac to a Linux server running IP Masq

William H. Magill wrote:

> On 28 Aug, 2005, at 08:53, Art Alexion intoned:
>> I can now establish an Internet connection on the iBook, but having
>> trouble with certain sites.  Some pop up instantly (google, CNN), 
>> others
>> load slowly (BBC, Apple), and others (most) won't load at all (Yahoo,
>>  I'm thinking this is a DNS issue, but I pointed the
>> iBook to the same Verizon DNS servers that are working fine on the
>> Ubuntu and win2k machines.
> The speed with which a site loads has nothing to do with the DNS, but 
> rather with Network Topology. Many "popular" sites use "caching 
> services" such as Akamai, to speed their load times.
> Since you have a new iBook, I assume you have 10.4.2 (Tiger).


> Open a terminal window (Applications/Utilities/terminal) and use 
> "netinfo" or "dig" to see how fast the actual DNS queries return.  
> You can then use "traceroute" to see what the actual path and 
> response times to various servers happen to be.

OK.  There is a gui netinfo, no text based program.  "dig" worked, but I
wasn't sure what the output meant.  I did a "traceroute" for one of the
URLs that I could not browse and after 16 IP stops it started returning
asterisks (*) only.

I turned off DHCP.  Tried again to set it up with a manual IP
(  Added that IP to the Linux server's host file.  Still
the same problems with a few Internet sites accessible, but not most.

I think this is a server configuration problem because connecting the
iBook directly to the modem and switching to PPPoE, gives me a "perfect"

Thing is, this (manual configuration) is the same thing I did to connect
a windows machine to the server and the windows machine accesses the
shares and the Internet fine.

The only other thing I did with the windows machine that I didn't do
with the iBook is to add the other machine on the lan to the iBook
client's host file.

> As for Verizon... they have apparently made some kind of significant 
> change in the past week or so. I have suddenly found my host 
> blacklisted and unable to communicate with others on So 
> far, Verizon has not bothered to return any of my communications with 
> them.
> Verizon has never supported Macs, so that you are having problems 
> using one if they have changed things recently would not be surprising.

They have for the past year that I have been using them.  At least they
say they do; I have never before had the need to use Mac support.

Officially, they don't support Linux, either, but most of the time that
I have had to call, they have worked with me using Linux.  They tend not
to know the Linux commands and syntax, but they work with you to
diagnose and solve the problem if you do.  Occasionally, you get someone
who actually knows the Linux apps, too.


Art Alexion
Arthur S. Alexion LLC
arthur [at] alexion [dot] com
aim: aalexion
sms: 2679725536 [at] messaging [dot] sprintpcs [dot] com

PGP fingerprint: 52A4 B10C AA73 096F A661  92D2 3B65 8EAC ACC5 BA7A
The attachment -- signature.asc -- is my electronic signature; no need for alarm.
Info @

Key for signed PDFs available at
The validation string is TTJY-ZILJ-BJJG.

Attachment: signature.asc
Description: OpenPGP digital signature

Philadelphia Linux Users Group         --
Announcements -
General Discussion  --