JP Vossen on 13 Nov 2008 17:56:53 -0800

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[PLUG] Ubuntu 8.04 --> 8.10 upgrade

I did an an Ubuntu 8.04 --> 8.10 upgrade over last weekend and I thought 
I might report some issues I had to work around.  Overall it went really 


1) 'update-manager -c' didn't give me an option to upgrade to 8.10.  -d 
worked though.

2) update-manager kept crapping out with "error authenticating some 
packages", which was related to my odd sources.list.

3) When I tried to run it a second time, update-manager a) would NOT 
give me the option to update to 8.10 and b) told me the system was 
up-to-date.  Reverting the 'intrepid' sources.list to the 'hardy' one 
allowed a re-try.

3) After the install, there was a graphics issue (as expected) but 
Ubuntu made it trivial to correct!

Of particular note, I have whole-disk encryption (per 8.04 alternate CD 
installer) and that worked great.


1) I should mention that as far as I am aware, the strongly recommended 
method for in-place upgrades is to use the GUI 'update-manager -c'.  As 
noted that's supposed to give you an update to upgrade to the next 
"distribution release," but it didn't.  'update-manager -d', which is 
"the latest devel release" gave me the option to update to 8.10, not 
sure why -c didn't.  This may be related to lag on mirrors, deliberate 
lag to space things out, my sources.list or something else.  No big deal.

2) It took several rounds of trial and error before I got this working. 
  For a while, no matter what I did, I'd get:
	"error authenticating some packages"
and update-manager would crap out.

First, even though it *told* me it had commented out some non-standard 
repos, it lied; it hadn't.  So I commented them out in the Hardy 
source.list and ran it again (but see #3).

Second, I use 'approx' as a local package cache, but for some reason I'm 
still using the older, kind of in-line syntax like this in 
deb    hardy           main 
restricted universe multiverse
deb    hardy-updates   main 
restricted universe multiverse
deb hardy-security  main 
restricted universe multiverse

update-manager didn't like that at all, but it didn't tell me that, it 
gave the misleading "error authenticating some packages" message.

The alternative to my syntax is to use /etc/apt/apt.conf with a proxy 
setting like:
	Acquire::http::Proxy "";;

AFAICT that Just Worked, and I did verify with a sniffer that it's still 
using the local proxy.  I'll switch all my machines over to that when I 
upgrade them, I guess.

3) When I'd run update-manager again after it crapped out, it would a) 
NOT give me the option to update to 8.10 and b) tell me the system was 
up-to-date.  I suspect A was because sources.list already said intrepid 
and B was because 8.04 really was fully up-to-date, but that's a 
dangerous disconnect.  The way to get update-manager to "work" was to 
revert the 'intrepid' sources.list to the 'hardy' one like 'sudo cat 
/etc/apt/sources.list.distUpgrade /etc/apt/sources.list' and try again.

4) On reboot after the install, I got:
	"Ubuntu is running on low-graphics mode"
	(EE) Problem parsing the config file
	(EE) Error parsing the config file
The next screen gave me:
	( ) Run Ubuntu in low-graphics mode for just this session
	(o) Reconfigure the graphics
	( ) Troubleshoot the error
Reconfigure the graphics gave me:
	( ) Use default (generic) configuration
	(o) Create new configuration for this hardware
	( ) Use your backed-up configuration
which totally didn't work, it just gave me a black screen and stopped. 
Killing X didn't help, thought I'm not sure I was in X yet anyway.

The second time I tried "Use default (generic) configuration" which told 
me it backed up the config, created a generic one and to restart.  That 
worked fine.

When it came up I checked the drivers menu and was offered:
	NVIDIA accelerated graphics driver (version 173)
	NVIDIA accelerated graphics driver (version 177) [Recommended]

An info box also came up that told me that the quit button could be 
replaced with a status menu if I wanted, so I gave that a shot.

I was greeted with this when I logged in via SSH:
   System information as of Sat Nov  8 16:50:01 EST 2008

   System load:  0.11              Swap usage:  0%  Users logged in: 1
   Usage of /:   71.1% of 105.61GB Temperature: 37 C
   Memory usage: 11%               Processes:   136



Finally, if anyone has gotten this far, this is on the Dell D630 I've 
been using for presentations lately.  One of the problems is that the 
NVidia binary blob driver is, well, terribly binary for working with 
projectors; it works fine or very badly, and I've yet to figure out how 
to hack it.  I was really hoping Intrepid is going to help (but since I 
think the problem is the NVidia driver, I wasn't really expecting it 
to).  As we found out Monday night, it didn't help.  But fortunately it 
liked Coredial's projects well enough. :-)

Basically, when I connect the projector, about 30% of the time it Just 
Works and everything is great.  The rest of the time it "autodetects" 
with a max resolution of 640x480, which is useless.  I can't figure out 
how to hack it to force something more useful though I haven't spent a 
great deal of time on it, and the usually helpful Dell/Linux ML has not 
been helpful.

If anyone has any suggestions I'd appreciate it.

JP Vossen, CISSP            |:::======|        jp{at}jpsdomain{dot}org
My Account, My Opinions     |=========|
"Microsoft Tax" = the additional hardware & yearly fees for the add-on
software required to protect Windows from its own poorly designed and
implemented self, while the overhead incidentally flattens Moore's Law.
Philadelphia Linux Users Group         --
Announcements -
General Discussion  --