Joe Rosato via plug on 12 Jul 2020 08:15:34 -0700

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

Re: [PLUG] Remote to an Ubuntu desktop

I posted this a while back but dumping here, might speed up a solution:

Your box needs Xvfb, x11vnc and a window manager. In short it tunnels vnc to your host (since x11vnc security is ehh) and you use a vncviewer to open a small window session with Xvfb (virtual frame buffer).



ssh -t -L 5567:localhost:5567 username@box "nohup x11vnc -create -env FD_PROG="$PRG" -env X11VNC_FINDDISPLAY_ALWAYS_FAILS=1 -env X11VNC_CREATE_GEOM=1024x768x16 -gone 'pkill Xvfb' -bg -noxinerama -nopw -noxdamage -noipv6 -rfbport 5567" &

vncviewer -depth 8 -encodings "copyrect tight hextile" localhost:5567

On Sun, Jul 12, 2020 at 10:08 AM Walt Mankowski via plug <> wrote:
On Sat, Jul 11, 2020 at 08:12:57AM -0400, Walt Mankowski via plug wrote:
> Thanks to everyone for all the tips! I think Chrome Remote Desktop
> won't work for me since I might be viewing patient data (I work for a
> research lab in Penn's med school) and it sounds like it might be a
> HIPAA violation.
> x11vnc over a SSH tunnel sounds like what I was looking for. I'll give
> it a try this weekend and report back.

Here's a quick update:

Last night I tried out x11vnc but I couldn't really get it to
work. The documentation [1] seems to me that I should see the exact
desktop I'd see if I were to login at work. Instead what I see is the
Ubuntu desktop background, but there are no icons. It doesn't respond
to mouse clicks. If I try to type anything, 90% of the screen turns
dark purple.

I suspect what may be happening is that I have 2 monitors at work and
only 1 at home, and I'm seeing the wrong one. I fiddled with the
options in TigerVNC but nothing seemed to work.

This morning I tried out NoMachine on the advice of work's IT
guy. That seemed to do exactly what I was looking for with a minimum
of fuss. It's a little wonky in that the desktop is bigger than my
monitor so I have scrollbars. It's possible I can tweak some settings
to get rid of that but it's certainly usable for now.

Thanks everyone for the advice. I might try out some of the other
options folks suggested, but I think I'm good for now.


Philadelphia Linux Users Group         --
Announcements -
General Discussion  --
Philadelphia Linux Users Group         --
Announcements -
General Discussion  --