Michael Whitman on Thu, 25 Jan 2001 09:57:15 -0500

[Date Prev] [Date Next] [Thread Prev] [Thread Next] [Date Index] [Thread Index]

[PLUG] emacs and termcap

I installed a debian system.
Then I tried to install emacs from a tar.gz - I did the standard install,
the only parameter i gave was '--with-x=no'.

When I tried to run emacs it told me that it couldn't find the termcap

I tried to do some troubleshooting and found out about the TERM variable.
I checked out the TERM variable on my RH system, saw it was vt320 so I set
TERM on my debian system to vt320.

Then I started getting the error 'vt320: unknown terminal type' when I tried
to run vi, emacs, or even a 'clear'.

So then I tried to undo what I had done with 'unset TERM' and TERM="", to no
avail, then I got '  : unknown terminal type' .

Meanwhile i found out I am supposed to have an /etc/termcap file on the
debian system but it wasn't there, so I copied the one from my RH system.
This stopped emacs from complaining about the lack of a termcap database.

So in conclusion - right now emacs runs if variable TERM is set to 'vt320',
but vi and 'clear' complain about an unknow terminal type.

So by this point it should be clear that I am clueless.  Can anyone
enlighten me or point me somewhere?

Philadelphia Linux Users Group       -      http://www.phillylinux.org
General Discussion  -  http://lists.phillylinux.org/mail/listinfo/plug